Refactoring: ImtLinkSet is now ImtLinkGrp, and other changes
Posted by mholmes on 22 Oct 2010 in Activity log
It makes more sense to have a class which handles a <linkGrp>
element to be called ImtLinkGrp
, so I've refactored the code and changed the file names. I've also made the namespace handling more sophisticated, so if the ImtLink
or ImtLinkGrp
classes have an assigned namespace, then they use createElementNS()
to write themselves, but if not, they use createElement()
. Finally, I've made ImtLink
more sophisticated in its handling of linkType
and nsUri
properties: if it has a parent ImtLinkGrp
, then it uses the properties from that, but if not it uses its own.